YuniquePLM

How can i get YuniquePLM, Is it compatible with v9.0. Do I've to purchase it separately or its included in the package?
Tagged:

Comments

  • Karin MeschzanKarin Meschzan Gerber Staff 💛
    Dear Muhammad,
    you will have to purchase YuniquePLM via your sales rep. The latest version of YuniquePLM is  only compatible with AccuMark V12.
    Will try to get the sales rep contact you also regarding upgrade of your AccuMark seats.

    Regards
    Karin
Sign In or Register to comment.